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INTRODUCTION AND USE OF QGIS (I) 

A. Introduction 

This manual and practical tutorial describes the process of creating tsunami inundation 

maps using a geographic information system (GIS), specifically QGIS. The tsunami 

inundation model results used in this manual are based on data from the Cedeño, 

Honduras model, produced by the MOST numerical model (ComMIT interface). The 

original version of the manual (Spanish and English) was prepared in Spanish by 

Engineer Carlos Rodriguez as part of TEMPP – Honduras, Central America Pilot (2015 – 

2017). In 2017 and 2018 TEMPP training was conducted in the Indian Ocean, organized 

by the ICG/IOTWMS and the Indian Ocean Tsunami Information Center (IOTIC), and the 

English manual was updated. In 2018 and 2019, the manual was used as an evacuation 

mapping learning activity within the ITIC Training Program (ITP) in Chile (2018) and in 

Hawaii (2019), and further updates were made to account for the new tools from Version 

3.8.2 “Zanzibar”. In 2021, the manual was updated by Jenna Kent from the Honolulu, 

Hawaii International Tsunami Information Center (ITIC) to reflect the QGIS version 3.20.2 

“Odense”. In 2023, the manual was updated by Desireé Bayouth García from the 

Mayaguez, Puerto Rico International Tsunami Information Center Caribbean Office (ITIC-

CAR). The 2023 manual update aims to provide an overview of the workflow for preparing 

tsunami evacuation maps using QGIS regardless of the software version, with included 

examples prepared using the QGIS version 3.26.0 “Buenos Aires”. 

 

 

B. Introduction to QGIS 

Quantum GIS (QGIS) is a free and open-source cross-platform desktop geographic 

information system application that supports viewing, editing, and analyzing geospatial 

data. The project was initially released in July 2002 with the initial objective of providing 

a GIS data viewer. QGIS has reached a point in its evolution where it is being used by 

both individuals and corporations to meet their daily needs for viewing, analyzing, and 

managing GIS data. QGIS provides a growing range of skills through basic and 

complementary roles. Users can view, manage, edit, analyze data, and design maps that 

can be printed in different formats. QGIS is written in C++, Python, and Qt. It runs on 

Microsoft Windows, Linux, MacOS, and Android platforms. 

 

 

C. System/Hardware requirements and installation 

New versions of QGIS are released regularly. If using the software please review the 

minimum and recommended system requirements for the current version, most stable 

version, or other version of interest on the page Download QGIS for your platform. 

 

 

https://www.qgis.org/en/site/forusers/download.html


D. Plugin installation 

QGIS Plugins recommended to develop Tsunami Evacuation Maps: 

• QuickMapServices: Facilitates users to add the web map services from Google 

Maps, OSM, NASA, etc. 

• QuickOSM: Executes QGIS specific queries for information from Open Street 

Maps (OSM data). 

• QGIS Resource Sharing: Downloads the database for UNOCHA Humanitarian 

Icons, which can be used to prepare standardized tsunami evacuation maps. 

• Heightmap Export: Prepares and exports a 16-bit PNG image from DEM data. 

 

Objective. Install the Plugins required to develop Tsunami Evacuation Maps. 

QGIS Step 1. In the QGIS Menu Bar click Plugins > Manage and Install Plugins… 

 
 

QGIS Step 2. In the Plugin dialog window select Not installed. Type the name of the 

plugin of interest, select it and click the lower right button that says Install Plugin. Follow 

this step for the rest of the required plugins. 

 



 

 

E. OCHA icons and fonts installation 

The United Nations Office for the Coordination of Humanitarian Affairs (UNOCHA) 

created standardized icons and fonts in various GIS ready formats for ESRI (ArcMap and 

ArcGIS Pro) and QGIS. Creating evacuation maps using simple and universally 

recognized symbols is essential to the maps’ success in saving lives and reducing 

tsunami impacts. For this reason, we recommend using only the UNOCHA icons and 

fonts for evacuation maps. These can be installed using the QGIS Resource Sharing 

plugin previously installed. 

 

Objective. Install the OCHA icons and fonts to develop standardized tsunami 

evacuation maps. 

QGIS Step 1. After installing the QGIS Resource Sharing plugin select Plugins > 

Resource Sharing > Resource Sharing in the QGIS Menu Bar. 

 
 

QGIS Step 2. Once the QGIS Resource Sharing Window is open search for the 

collection UNOCHA Humanitarian Icons 2018 and click the lower right button that says 

install. A window indicating that the installation is complete will be displayed. 



 

 
 

 

F. Selection of the project’s coordinate system 

Before importing the data to use for developing tsunami evacuation maps select the area 

of interest’s coordinate system. 

 

Objective. Select the coordinate system of the country or region for which the tsunami 

evacuation map will be developed. 

QGIS Step 1. In the QGIS Menu Bar click Project > Properties… 



 
 

QGIS Step 2. In the Project Properties dialog window select CRS. In the Filter section 

type the name of the Coordinate Reference System (CRS) corresponding to the country 

or region of interest, select it, click Apply and OK. For this manual example based on 

the Cedeño, Honduras model the selected CRS is WGS 84 / UTM zone 16 N and the 

Authority ID is EPSG:32616. 

 

 

 

G. Addition of vector and raster data layers (basics to know during the map preparation) 

Raster and vector datasets provide information of the area of interest and are used in GIS 

software for developing tsunami inundation maps. 

 



Objective. Import raster and vector datasets. 

QGIS Step 1. In the QGIS Menu Bar click Layer > Data Source Manager. 

 

QGIS Step 2. In the Data Source Manager dialog window select Vector or Raster. If 

importing a vector dataset, select Vector and browse for the Vector dataset of interest 

and click Add. If importing a raster, select Raster and browse for the Raster dataset of 

interest (*.tif) and click Add. 

   

 
 

 

H. Addition of satellite imagery (basemaps) using the QMS plugin. 

Satellite imagery provides reference of the area of interest and is used in GIS software 

for developing tsunami inundation maps. 

 

Objective. Import basemaps. 



QGIS Step 1. Ensure that the QuickMapServices plugin is installed. In the QGIS Menu 

Bar click Web > QuickMapServices > Search QMS. 

 
 

QGIS Step 2. In the Search QMS window added to the project type keywords 

associated to basemaps of interest and results will list services associated. Click Add 

and the selection will be included in the Layers panel. For this manual example based 

on the Cedeño, Honduras model, “satellite” was typed to obtain a list of associated 

services and ESRI Satellite (ArcGIS/World_Imagery) was selected.  

 
 

 

 

 

 

 

 



FINALIZING INUNDATION LAYERS USING QGIS (II) 

This manual section covers the use of QGIS to finalize the development of a tsunami 

inundation layer based on a numerical modeling output in GeoTIFF raster file format from 

Community Model Interface for Tsunami (ComMIT). For information and training on 

ComMIT and its capability for exporting tsunami model runs in multiple formats visit the 

NOAA Center for Tsunami Research ComMIT webpage. 

 

A. Preparation of the final tsunami inundation extent layer 

Objective. After selecting a coordinate system projection in the GIS software of interest, 

import the tsunami inundation modeling results (raster) to your project. 

QGIS Step 1. Add the .tif raster layer, exported from ComMIT, to QGIS. 

 

Objective. Reproject the tsunami inundation raster layer to the project’s coordinate 

system. 

QGIS Step 1. In the QGIS Menu Bar click Raster > Projections > Warp (Reproject)… 

 
 

QGIS Step 2. In the Warp (Reproject) dialog window search the Input layer to reproject, 

specify the Target CRS, and select Save to File… in Reprojected. After specifying the 

parameters of interest and the location to save the file to be reprojected click Run. The 

reprojected raster will be added to the Layers panel and Map View. 

https://nctr.pmel.noaa.gov/ComMIT/


 

 
 

Objective. Convert the reprojected raster to a polygon vector layer. This conversion will 

allow for the inundation layer to be easily used and manipulated during the layer 

generation and editing and evacuation map design process. 

QGIS Step 1. In the QGIS Menu Bar click Raster > Conversion > Polygonize (Raster to 

Vector)… 

Reprojected layer added 
to the Layers panel. 



 
 

QGIS Step 2. In the Polygonize (Raster to Vector) dialog window search the Input layer 

to vectorize, and select Save to File… in Vectorized. After specifying the parameters of 

interest and the location to save the file to be vectorized click Run. The vectorized layer 

will be added to the Layers panel and Map View. 

 
 

Objective. Use the vectorized layer’s attribute table to select the features where the 

modeling output indicates that a tsunami generated flooding. Once these features are 

selected, export or save them as a new vector layer. This selection will allow for the final 



layers to be used in the evacuation map design process to only display the inundation 

extent data. 

QGIS Step 1. Right click on the polygon (output of QGIS step 3) and click Open Attribute 

Table. 

 
 

QGIS Step 2. Click Select features using an expression in the Attribute Table. 

 
 

QGIS Step 3. In the blank query space type “DN >= 0” and click Select Features. All the 

features with a value greater than or equal to zero in the vectorized layer’s DN column 

will be selected. The total amount of selected features will be indicated in the Attribute 

Table dialogue window and visible in Map View. 



 

 
 

QGIS Step 4. Right click on the polygon (output of QGIS Step 3) and click Export > Save 

Selected Features As… 



 
 

QGIS Step 5. In the Save Vector Layer As… dialogue window click Browse and specify 

the location to save the file and file name, check the Save only selected features box 

option, and click OK. The layer containing only the selected features will be added to the 

Layers panel and Map View.  

 
 



Objective. Merge the multiple polygon features of the previously exported vector layer 

into a single polygon feature. 

QGIS Step 1. In the QGIS Menu Bar click Vector > Geoprocessing Tools > Dissolve… 

 
 

QGIS Step 2. In the Dissolve… dialog window search for the Input layer to dissolve, select 

Save to File… in Dissolved, and click Run. The dissolved layer will be added to the Layers 

panel and Map View.   

 



 
 

Objective. Modify the dissolved polygon’s outline by smoothing the vector to minimize a 

pixelated or sharp appearance. The automatic vectorization of data can result in a 

pixelated polygon layer that varies and depends on the resolution of data per region of 

interest. The output layer from this process will be used for data display/presentation 

purposes during the evacuation layer generation and evacuation map design process.  

QGIS Step 1. In the QGIS Menu Bar click Processing > Toolbox, type “Smooth” and 

select the tool. 

 

 
 



QGIS Step 2. In the Smooth dialog window search for the Input layer to smooth, select 

Save to File… in Smoothed, and click Run. The smoothed layer will be added to the 

Layers panel and Map View. 

 

 
 



Objective. Add a buffer zone to the smoothed polygon output of the tsunami hazard zone 

to consider uncertainties of the tsunami modeling. Follow IOC Manuals and Guides 82 

Preparing for Community Tsunami Evacuations – From Inundation to Evacuation Maps, 

Response Plans, and Exercises (MG-82) for details and considerations when selecting 

buffer zone values. The output layer from this process will be used as the tsunami 

evacuation layer during the evacuation map design process. 

QGIS Step 1. In the QGIS Menu Bar click Vector > Geoprocessing Tools > Buffer… 

 
 

QGIS Step 2. In the Buffer dialog window search for the Input layer to add a buffer to and 

select Save to File… in Buffered. After specifying the parameters of interest and the 

location to save the file to add a buffer to click Run. The buffered layer will be added to 

the Layers panel and Map View. For this manual example based on the Cedeño, 

Honduras model, a 10 m buffer zone was added to the tsunami hazard zone. 

https://unesdoc.unesco.org/ark:/48223/pf0000373019
https://unesdoc.unesco.org/ark:/48223/pf0000373019
https://unesdoc.unesco.org/ark:/48223/pf0000373019


 

 
 

 

 

 

 



DEVELOPING TSUNAMI EVACUATION MAP USING QGIS (III) 

This manual section primarily covers the use of QGIS to develop a tsunami evacuation 

map based on the tsunami inundation layer prepared in section II and datasets of interest. 

The section also provides a guidance example on the use of UNOCHA symbols in QGIS 

for the preparation (plugin installed in section I) of maps following standardized 

symbology. 

 

A. Datasets required for the development of a tsunami evacuation map 

Objective. Import the datasets required for developing a tsunami evacuation map to 

your GIS software of interest. 

QGIS Step 1. Import the vector and raster datasets. 

1. Georeferenced imagery - The imagery is a key element for the development of the 

map and must be as recent as much of the georeferenced information that is 

displayed on the map. It also serves a basis for better decision making when 

making complex editing and identifying highly sensitive or more vulnerable and 

fragile areas. 

2. Digital Terrain Model – Can be a grid text as an image with elevation attributes. 

This layer allows adding a suitable color ramp along vulnerable coastal areas. 

3. Tsunami inundation vector layer – This polygon layer is vital to the development of 

the evacuation area as it defines the flood zone and gathers topographic elements, 

road systems, and other natural elements easily recognized by the community to 

design and refine the tsunami evacuation zone. Typically, the evacuation zone is 

not wider than +/- 30% of the flood zone limits. 

4. Tsunami evacuation vector layer – This polygon layer is the recommended 

evacuation area and vulnerable area prepared for the community of interest. This 

zone is designed by the map developer based on the tsunami modeling outputs 

and vector layer and is openly discussed with the community. 

5. Road network vector layer – This polyline layer is vital for determining evacuation 

routes to be displayed on the evacuation map. Most communities are familiar with 

the road systems in the area and often can recommend the best options for 

evacuation routes using public roads or other routes. 

6. Water bodies vector layer – Polygon layers that display mangroves, lakes, or 

ponds, and other low lying areas where water may be present are important to 

consider when determining evacuation routes. Typically, in water affluent areas 

there are bridges that should be inspected to determine if they are at risk of 

collapse or if there is critical structural failure. Water bodies are a critical factor 

because they contain a large volume of water. 

7. Infrastructure vector layer – The specific elements on the map known as landmarks 

or benchmarks are places easily recognized by the general population. They 

provide effective location awareness to make critical decisions in a relatively short 



period of time. The infrastructure or benchmark polylines and/or polygons can 

include, but are not limited to: airports, schools, academic/education centers, 

hospitals, primary health care centers, springs, seaports, marinas, anchoring 

areas, beaches and resorts, bridges, police and fire department offices, camping 

sites, touristic areas of interest, shelters, and assembly points. 

8. Assembly points – This point layer provides the coordinate locations of designated 

assembly points for the evacuation map and can be displayed following the 

UNOCHA symbols. 

9. Evacuation routes – This point or polyline layer will provide the coordinate locations 

of geometries that will be displayed with an arrow symbology pointing towards the 

recommended and general direction of the evacuation route to assembly points. 

 

 

B. Symbology change – Standardized maps 

Objective. Verify that the added infrastructure layers have the project’s coordinate 

reference system. 

QGIS Step 1. After adding to QGIS the infrastructure layers, verify in the Layers panel 

that the layers have a coordinate reference system. If they do not, a question mark will 

appear to the right of the layers’ name. 

 
 

QGIS Step 2. Click on the question mark and when the dialog window opens, search 

and/or select the projection that corresponds to the ongoing project and click OK. For this 

manual example based on the Cedeño, Honduras model the selected CRS is WGS 84 / 

UTM zone 16 N and the Authority ID is EPSG:32616. 

Layers without a 
Coordinate Reference 

System. 



 
 

Objective. Use the UNOCHA symbol plugin to standardize the display of infrastructure 

layers on the map. 

QGIS Step 1. Right click on the infrastructure layer of interest and go to Properties… 

 
 

QGIS Step 2. Select the Symbology tab and click on Add symbol layer. This additional 

symbol layer will be added to prepare a layered symbol that is similar to the ones from 



other map examples. The “Simple Marker” layer appears under “Marker” after clicking 

Add symbol layer. Select the sublayer and use the arrows to the right to move them up 

or down to overlay them, or change the Symbol layer type. For this type of symbology, 

keep the SVG Marker layer above the Simple Marker layer. 

 
 

QGIS Step 3. Select the SVG Marker layer. In the SVG browser, in SVG Groups select 

collections > UNOCHA Humanitarian Icons 2018. Next to SVG Groups, type keywords of 

associated infrastructure of the layer of interest in the SVG Images search area. For this 

manual example the Schools layer was selected, “school” was typed in the search box 

and the fourth symbol was selected. 

Use to move up or 
down the symbol 

layers. 



 
 

QGIS Step 4. Select the Simple Marker layer. For this manual example the square symbol 

shape was selected. 



 
 

QGIS Step 5. Modify the color and sizes of the added symbol layers and markers for 

each. The sizes will vary as they depend on the extent and scale of the area of interest 

as well as the symbol color and style used for the map. 

 
 

Note (optional step). If determining a standard symbology to use for future maps, save 

these styles instead of manually setting them up per layer. In the bottom of the Layer 

Properties – Symbology dialog window click on Style > Save Style… to save the symbol 

layer preset and click on Style > Load Style… to import a previously saved symbol layer 

preset to use in another layer. 

For this example the SVG Marker 

color was changed to white and the 

square to blue with a black border. 

The SVG Marker size is smaller than 

the Simple Marker for design 

purposes. The colors, shapes, and 

design will vary per map or country. 



 
 

QGIS Step 6. Repeat the previous steps per infrastructure layer. 

 

Note. Regarding the evacuation routes dataset, it is also recommended to use an editing 

software to add arrows that indicate evacuation direction during the tsunami evacuation 

map development as these could be constantly changed during revision processes. Once 

the final evacuation arrows are determined, a shapefile including them can be prepared. 

 

C. Determining the optimal evacuation route 

Refer to MG-82 for considerations on determining the tsunami evacuation route. In 

addition to these considerations, GIS techniques such as network analysis support the 

selection of evacuation routes based on providing the shortest distance between specified 

locations, for example road networks and assembly points. In ArcGIS the Network Analyst 

extension is available and in QGIS the tool Network Analysis is available. Road networks 

and slope datasets (extracted from the DEM) are often used to employ this technique. If 

road network layers are unavailable or incomplete use the OpenStreetMap plugin in QGIS 

or go directly to their website to extract, download, and save as a shapefile the road 

network of the area of interest. For network analysis purposes all road segments in a 

single shapefile layer must be connected, use snapping tools to achieve this before 

employing the technique. 

 

https://docs.qgis.org/3.22/en/docs/training_manual/vector_analysis/network_analysis.html
https://docs.qgis.org/3.22/en/docs/training_manual/vector_analysis/network_analysis.html
https://docs.qgis.org/3.22/en/docs/training_manual/vector_analysis/network_analysis.html


FINALIZING TSUNAMI EVACUATION MAPS FOR PRINTING (IV) 

This manual section primarily covers the use of QGIS to develop the printable version of 

the tsunami evacuation map prepared in section III.  

 

A. Required elements for the evacuation map design. 

The evacuation map design process involves arranging map elements in an effective way 

that clearly and easily communicates spatial information to all users. Important 

considerations for the map review process:  

- Datasets in the Table of Contents ordered in such a manner that one layer’s 

symbology does not cover the symbology of another (e.g. infrastructure layers 

should be above a road network so that the road network does not cover the 

depicted symbology). 

- Labels in the final map should be added to infrastructure and areas that are 

commonly recognized by residents and tourists for easy identification and 

understanding. Consider the selected background basemap and colors used for 

the datasets symbology to select a legible symbology for labels. 

 

The following elements should be included in the final evacuation map: 

1. Title 

2. Legend 

3. North arrow 

4. Map scale 

5. Inset Map  

6. Entity logos 

7. Grids 

8. Date of production 

9. Agency contact information 

10. Disclaimer/Notes (if applicable) 

11. Project funding the tsunami modeling 

and/or relevant details 

12. Acknowledgements 

13. Labeled key infrastructure 

14. Labeled or listed assembly points 

(location name list also) 

 

B. Print Layout Guide 

After all the layers required for the tsunami evacuation map are added and organized its 

design can be developed. 

Objective. Prepare the final map for export after importing the required layers and setting 

up the symbology. 

QGIS Step 1. In the QGIS Menu Bar click Project > Layout Manager… In the dialog 

window select Empty Layout > Create… and when the Create Print Layout window opens 

type a name for the layout and click OK. After clicking OK a new window will open. 



 
 

QGIS Step 2. Click on the white canvas and the Item Properties tab on the right side 

panel will show information. Select the page size of interest for your project and map 

background. For this manual example based on the Cedeño, Honduras model the A4 

portrait template and white background was selected.  

 
 

QGIS Step 3. Select the Add Map toolbar button and drag the mouse over the canvas to 

draw the extent of interest. 

White canvas 



 
 

QGIS Step 4. The map will load from the active map canvas in QGIS. To adjust the map 

extent click on the Select/Move toolbar button. To zoom in and out of the map extent click 

the Move item content toolbar button, then click ctrl + scroll the mouse wheel. 

 
 

QGIS Step 5. Prepare a Spatial Bookmark to save the final map extent. Click View 

Current Map Extent in Main Canvas and the QGIS project window will be updated. In the 

QGIS Menu Bar click View > New Spatial Bookmark… In the Bookmark Editor window 

click on Calculate from > Layout Map > Map 1 (Map 1 contains the Evacuation Map 

elements). Click Save. 

Add Map 

Select/Move item 

Move item 
content 



 

 

View Current Map 
Extent in Main Canvas 



 
 

QGIS Step 6. Select the toolbar buttons such as Add Labels and Add Shape to add text 

such as the map title, date of production, agency contact information, disclaimer/notes, 

project funding information, acknowledgements, amongst others. 

 

 
 

QGIS Step 7. Select the Add Legend toolbar button and drag the mouse over the canvas 

to draw the extent of interest. A legend with all layers, and their names, that are currently 

on the Map Canvas will be generated. To remove the layers that are not of interest for the 

tsunami evacuation map click on the legend and in the Item Properties Tab on the right 

side panel deselect Auto update under Legend Items. Select legend items to remove and 

click on “Remove selected item(s) from legend”. Another alternative to remove the layers 

from the legend is to select “Only show items inside linked map”. To modify the label 

name of a layer double click it on the Legend Items section and change the text. To 

Add Shape 

Add Label 



rearrange the layers order use the arrows on the Legend Items section. Add a title to the 

legend on the Main Properties section. 

 

 
 

QGIS Step 8. Select the toolbar buttons North Arrow and Scale Bar and drag the mouse 

over the canvas to draw the extent of interest for each element. To change the North 

Arrow symbol click on the element, in the Item Properties Tab on the right side panel 

under Picture go to the SVG browser, in the App Symbols folder go to Arrows and select 

the preferred one. To modify the scale bar click on the element, in the Item Properties 

Tab on the right side panel under Scalebar modify the display units and segments. 

Updated and renamed 
legend items. 



 

 
 

QGIS Step 9. Select the toolbar button Add Map to add an inset. Drag the box to the size 

of interest and place where desired. Select the box and go to Item Properties > Overviews 

> Add a new overview. In the subsection Draw “Overview 1” overview select under Map 

frame “Map 1” which covers the extent of the evacuation map. If the name was modified 

select the corresponding one. The style of the inset, the extent it covers, and the basemap 

to display will depend per country or community. For this particular example the inset 

zooms out of the main extent, but does not include the whole country, and the imagery 

basemap was used. To update the extent under Map 2, in Item Properties click “Update 

Map Preview” and “Set Map Extent to Match Main Canvas Extent”. Then modify the 

Frame style. 



 

 
 

 

 

 

 

Add Map 

Map 2 

Select the added 
overview. 

Select Map 1 as the data frame. 

Click on the frame style to 
modify the Symbol layer type, 

color, and width. 

Update Map Preview 

Set Map Extent to 
Match Main Canvas 

Extent 



 
 

QGIS Step 10. Select the toolbar button Add Picture to add entity logos. Go to Item 

Properties > Picture, select Raster image and browse for the file. To display the pictures 

with higher quality click Resize mode and change to Resize Frame to Image Size. 

 
 

QGIS Step 11. Go to Item Properties > Grids > Add a new grid > Modify Grid… > Enable 

grid and modify the appearance and coordinates according to the country and community. 

Overview 1, red outline 
denoting the area that the 

evacuation zone map covers 



 
 

QGIS Step 12. Select the toolbar buttons such as Add Labels and Add Shape to add the 

remaining text for the map such as the date of production, agency contact information, 

disclaimer/notes, project funding information, acknowledgements, amongst others. 

 
 

QGIS Step 13. After completing the map, select the Export Settings and select the export 

format in Layout. 



 
 

 

 

 

 

 

 

 

 


