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Developed by the NOAA Center for Tsunami Research (http://nctr.pmel.noaa.gov) 
in collaboration with the International Tsunami Information Center (http://itic.ioc-unesco.org) 
 
TsuCAT information is available from http://itic.ioc-
unesco.org/index.php?option=com_content&view=category&layout=blog&id=2239&Itemid=2763  
 
Application specific questions and bug reports should be directed to: 
http://nctr.pmel.noaa.gov/TsuCAT 
 
Scenario based hazard assessment available through TsuCAT is primarily intended to support pre-
event tsunami response planning and exercise development.  During an event, TsuCAT may assist 
in early situational awareness (approximate scenario) prior to the availability of event-specific 
forecasts from national agencies or international tsunami service providers. 
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ABSTRACT 
 
The Tsunami Coastal Assessment Tool (TsuCAT) is a simple and quick, yet powerful 
tool for exploring the impact from many different tsunamis. It was developed by the 
NOAA Center for Tsunami Research (NCTR) to support the International Tsunami 
Information Center’s (ITIC) effort to provide countries with tsunami decision support 
tools. 
 
TsuCAT provides access to a Pacific database of tsunami modeling results from NOAA’s 
pre-computed catalog of sources (Propagation Database) to assist a country in its tsunami 
hazard assessment, tsunami exercise and response planning, and warning decision-making.  
Simulations for historical tsunami sources from NOAA’s National Centers for 
Environmental Information (NCEI) and the U.S. Geological Survey earthquake archive are 
also included.  
 
During an event, national tsunami warning centers must be able to assess their threat, and 
decide when to issue warnings based on their own alert level criteria.  For earliest decision-
making, especially for local tsunamis, a pre-computed, look-up database containing 
plausible warning scenarios and thresholds is often used.  TsuCAT may assist in early 
situational awareness (approximate scenario) prior to the availability of event-specific 
forecasts from national agencies or international tsunami service providers 
 
TsuCAT is platform independent and ‘stand-alone’ in that it runs on the Microsoft 
Windows, Apple Macintosh, and Linux computing platforms, and does not require Internet 
connectivity. All libraries, databases, and documentation are installed in their entirety on 
the host machine. The only requirement is a Java v1.8 or higher free installation 
  
Offshore maximum tsunami wave amplitude and arrival time are easily queried on the 
map. The generated map also provides Coastal Hazard Guidance, which is represented as 
the deep-ocean wave amplitude extrapolated to the coastline accounting for shoaling 
using the Green’s Law approximation.  A Coastal Hazard ‘Warning’ Polygon map layer 
is included, which is equivalent to the Pacific Tsunami Warning Center’s Coastal 
Tsunami Amplitude Forecast Polygon map, and also customizable.  An exercise tool is 
available to generate the PTWC test messages and enhanced graphical products for use 
during tsunami exercises.  The user is cautioned that when using real events from the 
event database that the test messages and enhanced graphical products produced will be 
based only on the closest source in the TsuCAT catalog and, hence, may not exactly 
match the PTWC-issued forecast.  The feature is meant only to assist in tsunami 
exercises. 
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1. Introduction and Background 
 
In 2014, the U.S. Pacific Tsunami Warning Center (PTWC) ceased provision of watches 
and warnings for countries throughout the Pacific Ocean. Enhanced products that include 
wave amplitude were developed and are now provided to offer forecast guidance. The 
2014 change now requires countries to be responsible for assessing their own threat, and 
deciding when to issue warnings based on their own alert level criteria.  In an effort to 
assist countries in their decision making, the International Tsunami Information Center 
(ITIC) and NOAA Center for Tsunami Research (NCTR) developed the Tsunami Coastal 
Assessment Tool (TsuCAT) that was distributed to delegates to the Twenty-seventh 
Session of the Intergovernmental Coordination Group for the Pacific Tsunami Warning 
and Mitigation System (ICG/PTWS-XXVII, March 28-31, 2017) 
 
TsuCAT provides access to a global database of tsunami modeling results from NOAA’s 
pre-computed catalog of sources (Propagation Database, GICA et al., 2008), and from 
NOAA’s RIFT model, to assist a country in its tsunami hazard assessment, tsunami 
exercise and response planning, warning decision-making, and education and outreach.  
Simulations for historical tsunami sources from NOAA’s National Centers for 
Environmental Information (NCEI) and the U.S. Geological Survey earthquake archive 
are also included.  The tool is a ‘standalone’ application not requiring the Internet, and 
can be used for outreach in remote locations, as well as during events when 
telecommunications are down. 
 
TsuCAT assists countries in response planning and preparedness by providing a tool that 
enables planners to determine where the worst case tsunami sources are located, how big 
the earthquake’s magnitude must be to directly threaten their coastlines, how much time 
they will have before the first tsunami wave hits, and how big the tsunami wave is 
expected to be.  This information can then be used to develop tsunami emergency 
response and evacuation plans, and to conduct tsunami exercises that will prepare 
response agencies and communities to be ready for the real event.  TsuCAT will create 
the PTWC text and enhanced graphical products that can be used for tsunami exercising.  
 
TsuCAT can also assist national tsunami warning centers with early situational awareness 
(approximate scenario) prior to the availability of event-specific forecasts from national 
agencies or international tsunami service providers.  As TsuCAT is a pre-computed 
database of plausible tsunami scenarios with customizable coastal hazard warning 
polygons, it could be useful as a look-up tool to provide a conservative assessment prior 
to PTWC tsunami forecasts (typically 30 minutes after the earthquake due to the time 
required to reliably characterize the earthquake source).   
 
This manual introduces the user to TsuCAT and describes the workflow and parameters 
necessary to access all functionality offered through the application.  
  



Tsunami Coastal Assessment Tool User’s Manual 
 

10 

2. Application Overview 
 
TsuCAT is a platform-independent application that was developed for hardware running 
Windows, Macintosh, and Linux operating systems and depends only on a Java 
installation (version 1.8 or higher).  A graphical user interface gives access to NOAA’s 
Database of pre-computed tsunami arrival times and maximum amplitudes. In this 
software release, the Database is populated with results of modeling with the MOST 
model for magnitudes greater than Mw > 8.0 and with the RIFT model (used by PTWC) 
for magnitudes less than Mw < 8.0.  
 
The Database contains results from more than 2000 model runs of the tsunami 
propagation Method of Splitting Tsunamis (MOST) code and PTWC’s Real-time 
Inundation Forecast of Tsunamis (RIFT) code. PTWC uses both models to calculate 
tsunami forecasts for countries in its international areas of responsibility (Pacific and 
Caribbean).  Information on RIFT can be found in the Users Guide for the Pacific 
Tsunami Warning Center Enhanced Products for the Pacific Tsunami Warning System 
(IOC Technical Series No 105, Revised edition. UNESCO/IOC 2014 (English; Spanish), 
and information on MOST can be found in Implementation and testing of the Method of 
Splitting Tsunami (MOST) model (NOAA Technical Memorandum ERL PMEL-112, 11 
pp). 
 

The MOST model runs form the basis of the Short-term Inundation Forecasting of 
Tsunami (SIFT) and are comprised of an initial thrust deformation on a standard 100km-
by-50km fault plane, and use seismic parameters appropriate to the hypocenter selected, 
with a slip value of 1 meter.  This 1-meter slip value gives them the name “unit sources”, 
and produces a moment magnitude (Mw) of 7.5 for each of the fault planes.  These pre-run 
models have been combined to represent earthquakes of larger magnitudes, and the wave 
amplitude for various combinations can be shown to the user to allow assessment of wave 
amplitude at any given location in the ocean basin.  While the standard 100km-by-50km 
fault plane works well for forecasting larger magnitudes using SIFT, magnitudes below 8.0 
have been run using the RIFT model with fault lengths decreasing appropriately with 
magnitude.  This allows accurate results over a range from Mw 6.5 up to the theoretical 
maximum of 9.6.  
 
Various ways exist to extrapolate offshore wave amplitude values to the coastline to 
account for shoaling, and the “Coastal Hazard Guidance” algorithm allows a very rapid 
assessment of hazardous areas along a regional coastline given only earthquake magnitude 
and epicenter location. 
 
TsuCAT allows the user to view the effect of an earthquake at any location along a 
coastline using the Propagation Database by calculating the maximum wave amplitude 
for various combinations of unit sources using the relationships between rupture length 
and magnitude as outlined in Wells and Coppersmith (1994).  Over 5,400 combinations 
are pre-calculated for magnitudes from Mw=6.5 to 9.6 in increments of 0.3, for all three 
major ocean basins: Pacific, Atlantic (including the Caribbean), and Indian.  As of 

http://www.pmel.noaa.gov/pubs/PDF/tito1927/tito1927.pdf
http://www.pmel.noaa.gov/pubs/PDF/tito1927/tito1927.pdf
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version 4.0, the scenarios cover the South China Sea and marginal seas of the Western 
Pacific.   
 
The full installation of TsuCAT includes all the combination files, and, therefore allows 
TsuCAT to run “stand-alone”, without an Internet connection.  Archives of coastline and 
historic earthquakes are also provided, allowing the user to search nearby tsunamis and 
magnitudes to make an accurate assessment of the hazard due to a tsunami for a given 
stretch of coast.  If the user has an Internet connection, new earthquake information is 
automatically queried from the USGS earthquake archives each time TsuCAT is run. 
This means that newly occurring events are available in near real-time.  Rendering the 
pre-run offshore wave amplitudes using the closest scenario to the desired epicenter takes 
only moments, so a rapid assessment for guidance is possible. 
 
 
 

2.1 Workflow 
 
TsuCAT was designed for a user to easily and quickly get a baseline feel for the possible 
impact of a tsunami along their Pacific coastline of interest.  An earthquake source from 
which to generate the tsunami is first selected either from a list of historical events or by 
choosing one or a combination of NOAA propagation database unit sources. Once 
selected, the workflow consists mainly of visualization choices, examples of which are 
shown in Figure 1. 
 
 

 
Figure 1: The TsuCAT workflow.  Once an earthquake source is selected, the user has 
options to visualize the impact on large and small scales. 
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3. The NOAA Propagation Data Base 
 
A pre-computed tsunami propagation database, that consists of deep-water wave 
elevations and flow velocities pre-computed for a continuous series of 50 x 100 [km] unit 
sources along all known subduction zones within each ocean basin, provides the sources 
used to construct the offshore wave amplitude database. Gica et al., (2008) provide 
details of database generation using the MOST model, including design and seismic 
considerations. This database is augmented with offshore wave amplitudes from the RIFT 
model for moment magnitudes less than Mw 8.0, where 50 x 100 [km] faults planes are 
too large.  The RIFT results are created using the same epicenter locations as the MOST 
results, but appropriately smaller length, width, and slip parameters.  The tsunami source 
approximates a shallow thrust fault earthquake. The database unit sources can be linearly 
combined to produce synthetic boundary and initial conditions of water elevation and 
flow velocities to initiate tsunami forecast computations.   

4. Graphical User Interface and Features 
4.1 Overview 
 
When TsuCAT is first opened (double-click the application icon), the main graphical user 
interface window comes up with the offshore wave amplitude [cm] and wave arrival time 
[hours] for the Great Japan Tsunami of 11 March 2011 shown by default (Figure 2). 
 

 
Figure 2: The Tsunami Coastal Assessment Tool main interface. 
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Event information is displayed in the top center panel, labeled “Event” (i.e., 11 Mar 2011 
05:46:00 (UTC) Mw: 9.1 Ep: 38.297° N, 142.372° E "JAPAN").  Colors on the map, 
from blue-to-yellow-to red, give a quick view of the tsunami maximum amplitude 
throughout the Pacific Basin.  Gradations of color are shown in a vertical color bar 
plotted in the lower right-hand side of the plot frame.  One-hour contours of wave arrival 
are shown in black. Both offshore wave amplitude and expected arrival of the first wave 
can be queried for any point by simply moving the mouse over the point of interest and 
reading the value off the status bar at the bottom of the application. An example of the 
status bar display is: 
 

 
 
The user can also pan and zoom the map in more familiar ways, either by click and drag 
(pan) or by double-clicking (zoom), or by using these buttons in the upper left of the map 
window:  
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4.2 Propagation database unit sources 
 
A clear star plotted on the map marks the requested epicenter of the earthquake that 
generated the event of interest. Blue rectangles outline the Propagation Database ‘unit 
sources.’   Once selected, the unit sources are filled white, and are shown as the NOAA 
Propagation Database codes with their respective weights, as used in the Short-term 
Inundation Forecast of Tsunami (SIFT) forecast application as well and in the 
Community Model Interface for Tsunami (ComMIT, TITOV et al. 2011) inundation 
model tool (Figure 3).  
 
  

 
Figure 3: The Propagation Database unit sources selected for the Great Japan tsunami of 
2011. 

 
 
In the case of the Japan 2011 event, empirical relationships between earthquake 
magnitude, rupture length, rupture width and area, and surface displacement, known as 
the Wells and Coppersmith relation (WELLS AND COPPERSMITH 1994) chose twelve unit 
sources in a 2-by-6 configuration for a total fault area of 120,000 km2 (200 km width and 
600 km rupture length).  The text representation for this source includes a weight and a 
reference code for each unit source:  
 
14.784*ki24a+14.784*ki24z+14.784*ki25a+14.784*ki25z+14.784*ki26a+ 
14.784*ki26z+14.784*ki27a+14.784*ki27z+14.784*ki28a+14.784*ki28z+ 
14.784*ki29a+14.784*ki29z 
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These unit sources and their weights can be viewed by selecting the “View->Fault 
Information” menu item in TsuCAT (Figure 4).  The above text representation can be 
copied-and-pasted by right-clicking on the table.  A complete description of the 
Propagation Database can be found in GICA et al (2008), and online at 
http://nctr.pmel.noaa.gov/propagation-database.html.  This text description can be used as 
a source in the ComMIT inundation tool. 
 
 

 
Figure 4: Unit Source table with weights showing the sources used from the Propagation 
Database for the given event, as well as seismic parameters for the model run. 

  

http://nctr.pmel.noaa.gov/propagation-database.html
http://nctr.pmel.noaa.gov/ComMIT/
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4.3 Earthquake events, magnitudes, and epicenters 
 
The epicenter for an earthquake (latitude and longitude of location) can be moved by 
editing the “Requested Epicenter, Lat: Lon:” values, or by right-clicking the clear 
epicenter star and dragging it (or “Command-click” on the Mac).  It turns green when 
dragged, and when dropped will find the epicenter for the closest unit source combination 
in the Propagation Database catalog (Figure 5).  Note that both the Requested Epicenter 
and the Closest in Catalog epicenters are shown, along with the distance between them. 
 
 
 

 
Figure 5: An arbitrary Mw=9.1 along the Kamchatkai-Yap (ki) subduction zone. 

 
The moment magnitude, Mw, can be edited in the upper panel text box labeled ‘Mw’ at 
the top of the application window.  Changes in Mw show how the impact to a coast might 
change when smaller or larger tsunamis are generated. The larger the earthquake 
magnitude, the greater the number of propagation database unit sources. An Mw=8.6 in 
the same location along the Kamchatkai-Yap subduction zone selects only 6 unit sources, 
instead of the 12 selected for the Mw 9.1 tsunami. Results from the smaller Mw show 
correspondingly smaller maximum wave amplitude (Figure 6): 
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Figure 6: Arbitrary Mw=8.6 along the Kamchatkai-Yap subduction zone. 

 
Users can also turn on the “Earthquake Epicenters” layer by selecting it in the panel to 
the left of the map.  All historic tsunamis contained in the NOAA Center for 
Environmental Information (NCEI/NGDC) Tsunami Database will be shown 
(https://www.ngdc.noaa.gov/hazard/tsu_db.shtml) (NGDC, 2000 BC- present). This list 
includes all events up through December 2019.  Events after January 2020 may be 
obtained from the USGS earthquake archive 
(https://earthquake.usgs.gov/earthquakes/search/) and are refreshed each time TsuCAT is 
launched, if an internet connection is found.  The most recent vetting of a USGS event is 
used each time the application is loaded. 
 
 
 
 
 
 
 
 
 
 
 

https://www.ngdc.noaa.gov/hazard/tsu_db.shtml
https://earthquake.usgs.gov/earthquakes/search/)
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Represented as purple dots on the map (Figure 7) the size of the dot is scaled with the 
size of the event.  The user can select the closest epicenter to an historic event by right-
clicking on the event of interest and choosing from a list of nearby events: 
 

 

 
Figure 7: Historical tsunamigenic earthquakes (purple dots) from the Global Historical 
Tsunami Database 
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The selected event is then shown (Figure 8) with a red ring around the selected event, and 
the selected event information is shown in the upper panel, including Epicenter, Mw, 
Date/time, Depth and nearest country: 

 
 

 
Figure 8: selected earthquake event 

All earthquake epicenters can be viewed by choosing the menu item “File->Select Event” 
(Figure 9).  This table can be sorted by Date, Mw, Latitude, Longitude, or Country and 
the selected event can be viewed in TsuCAT.  TsuCAT will show the offshore wave 
amplitude and Coastal Hazard Guidance for the scenario in its database with the closest 
epicenter location and Mw of the event, scaling file to the Mw of the selected event. 
 
 

 
Figure 9: Listing from the full earthquake database. 
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4.4 Coastal Hazard Guidance 
 
The Coastal Hazard Guidance (CHG) shown by TsuCAT represents the offshore wave 
amplitude that has been extrapolated to the coastline using a simple-depth based 
relationship to account for shoaling of waves.  The relationship or approximation is given 
by: 
  

 

 
where Hd is the water depth at the deep offshore grid point, Hs is the water depth at the 
coastal shoreline point and  is the wave amplitude at the shoreline approximated by the 
deep-ocean wave amplitude . The ratio of ocean depths, H, provides the scaling factor.  
 
The MOST model was run with a bathymetric grid resolution of 4 arc-min, while RIFT 
model runs were run with resolution that increases with smaller magnitude. This allows 
resolving the smaller wavelengths generated by these smaller faults.  Since the models 
use varying resolutions, the depth chosen for the deep water point deepens with lower-
resolution runs and is known as the cutoff depth. For each point along the coastline, then, 
the closest model grid point that is deeper than the cutoff depth is selected and scaled by 
the ratio.    
 
The Coastal Hazard Guidance (CHG) layer is viewed by selecting it in the left-hand 
“layers” panel.  This layer shows the Global Self-consistent Hierarchical High-resolution 
Shoreline (GSHHS) coastline color-coded by the nearest offshore model point and scaled 
to account for shoaling by the Green’s Law. Detailed information about the combined 
shoreline, rivers, and geo-political boundaries GSHHS dataset is available at: 
https://www.ngdc.noaa.gov/mgg/shorelines/gshhs.  The resulting scaled shoreline value 
is then colored in accordance with the color map.  The CHG color map shows gray for 
values that are less than 1 cm (essentially “no data”), green for values between 1-30 cm, 
yellow for values between 30-100 cm, and red for values above 100 cm.  The values for 
the CHG bins can be changed in the TsuCAT Preferences as discussed in 4.7 Other 
Features.  The CHG takes a few seconds to calculate, so when the user changes the 
magnitude or epicenter, TsuCAT calculates CHG in the background and renders the 
colored shoreline values when calculations are complete.  Coastal Hazard Polygons are 
colored according to CHG, so they, too, take a few seconds to render if the user changes 
the source selected. 
 
The Coastal Hazard Guidance values tend to be larger than the adjacent offshore 
maximum amplitude due to the scaling for shoaling, which is evident in Error! 
Reference source not found.. Green’s Law was designed for estimation of channel flow, 
so it provides the best coastal estimate where there are gently sloping bathymetries.  
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Figure 10: Coastal Hazard Guidance (CHG) based on Green’s Law scaling. 

 
Green’s Law makes the following assumptions:  

1. The coastline is linear and exposed to the open ocean.   
2. Tsunami waves near the coast behave as one-dimensional plane waves.   
3. There are no significant wave reflections and no dissipation by turbulence.   
4. The bathymetry varies slowly compared to the wavelength of the tsunami waves. 

Thus, for steep bathymetry, Green's Law can overestimate the wave amplitude.   
5. Cliff boundary conditions are used. In other words, the coast is assumed to be a 

vertical wall. 
 
Specifically, the Green’s Law approximation breaks down in areas of complex 
bathymetries. Therefore, where coastlines consist of bays, inlets, or are hidden by 
offshore islands, or where the sea bottom rises steeply to the shore, Green’s Law coastal 
wave forecasts will likely be in error.   
 
Actual amplitudes at the coast may vary from the forecast amplitudes due to uncertainties 
in the forecast and local features.  In particular, maximum tsunami amplitudes on atolls 
and at locations with fringing or barrier reefs will likely be much smaller than the Coastal 
Hazard Guidance indicates.  The offshore wave amplitude map should not be used to 
estimate coastal tsunami amplitude or impacts.  Deep-ocean amplitudes are usually much 
smaller than coastal amplitudes. 
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4.5 Coastal Hazard Polygons  
 
The Coastal Hazard Polygons layer shows the NOAA Pacific Tsunami Warning Center 
(PTWC) Coastal Tsunami Amplitude Forecast Polygons as colored by the TsuCAT 
Coastal Hazard Guidance (CHG), with the following simple algorithm: the 99th percentile 
maximum of all coastal points within a polygon is used to color the entire polygon, e.g. if 
the maximum CHG within a polygon is 67.2 cm, the entire polygon is colored yellow.  
This aggregation tends to be a “broad brush” algorithm, as can be seen in Figure 11: areas 
like the west coast of the United States and Canada that show mostly yellow coastal 
values have polygons that are shaded orange (High) because more than 1% of the coastal 
points in that polygon are in the high range.  Note that the user can set the ranges 
manually (in Preferences), but the standard values are: No Data <1 cm, Low between 1-
30 cm, Medium 30-100 cm, High 100-300 cm, and Extreme > 3 meters. 
 
 

 
Figure 11: Coastal Hazard (Warning) Polygons for a hypothetical Mw=8.9 in the 
Aleutian islands. 
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4.6 Custom Coastal Hazard Polygons 
 
TsuCAT gives the user the option to create their own coastal hazard polygons using the 
menu item “Edit->Add Custom Warning Polygons”.  To best use this option, the user 
should zoom to the region of interest before starting.  It is also a good idea to keep the 
Coastal Hazard Guidance map layer selected.  As an example, we will create a custom 
polygon around the Republic of Vanuatu by zooming into the region and selecting the 
menu “Edit->Add Custom Warning Polygon” (Figure 12). 
 
 
 

 
Figure 12. Zoomed into a region of interest around Vanuatu in preparation to create a 
Custom Coastal Hazard Polygon 

The Custom Coastal Hazard Polygon dialog appears, with a default unique name.  The 
first step is to name this polygon with an appropriate name.  We’ll choose “Vanuatu: 
Tafea” by typing it into the Name box.  Then we will click points surrounding the 
islands; when we’re done, we’ll click “OK” and the polygon will be rendered and added 
to the “Tree” of Coastal Hazard Polygons on the map layers panel on the left (Figure 12). 
The new Polygon will be rendered according to the Coastal Hazard within it, and updated 
automatically.  To delete the polygon, either right-click on its name in the layer list on the 
left, or right-click directly on the polygon and select “Delete Polygon” (Figure 14).  A 
warning dialog will appear to confirm the deletion.  
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Figure 13. A newly-created Custom Coastal Hazard Polygon named "Vanuatu: Tafea". 

  
Figure 14: Deleting a Custom Coastal Hazard Polygon. 
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The custom polygons are saved in Google Earth format (KML) in the application folder 
in a file named “Custom_Warning_Polygons.kml”.  Users can further edit the file by 
locating it (select menu item “Help->View Application Folder” then open the folder 
“etc”).  Double-clicking the Custom_Warning_Polygons.kml file will launch the free 
Google Earth application. 

 

4.7 Other Features 
 

Exporting Images 
 
The user may export the TsuCAT map as a “PNG” image file by choosing the menu 
“File->Export Map Image”.   
 
 

Customizing Coastal Hazard Range Bins 
 
The user may change the Coastal Hazard color bin cutoffs from the default values of 100 
cm for “High” hazard, 30 cm for “Medium”, and 1 cm for “Low” hazard.  These default 
values are in use at NOAA’s Pacific Tsunami Warning Center, and the user can reset to 
these values by pressing the User Preferences button “Reset to Defaults” (Figure 15). 
 
 

Offshore Wave Amplitude Color Map  
 
The user may choose between the NCTR color map, the MOST/SIFT color map used and 
the PTWC Enhanced Products RIFT color map: 
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Figure 15. TsuCAT User Preferences window allowing user to customize “Coastal 
Hazard color bins,” select Wave Amplitude color map, and select Internet map streaming 
using  "View->Stream Map Tiles from Internet." 

 

Additional Map Layers, Place Names 
 
The requirement that this tool “stand alone” (work without an internet connection) gives 
it the added benefit that it can be depended upon during an event, even if the only 
information a user has is location and magnitude.  However, there are two ways in which 
an internet connection will make this tool even more useful.   
 
The first is that the user may elect to load base-layer map image tiles by opening the User 
Preferences dialog under “Edit->Preferences” (Figure 15).   Background image “tiles” 
then stream from a server as an online map would in a browser.  This has the advantage 
that place names are shown that might not show in the stand-alone database of places 
(populations less than 15,000).  The stand-alone place name database is used under 
Creative Commons license from GeoNames.org. 
 
If the user pans and zooms, new background imagery appropriate to that zoom level is 
loaded, keeping the application more responsive, as the grey continents need not be 
refreshed each time a user pans or zooms.  The Provider for background tiles can be 
selected for a different look to the basemap by choosing the User Preference “Set Map 
Tile Provider.”  In addition to clear advantages of this feature, there are, however, 
drawbacks that are described here.  The first drawback is that the coastline for the Coastal 

http://creativecommons.org/licenses/by/3.0/
http://www.geonames.org/
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Hazard Guidance is still the medium-resolution GSHHS dataset. This means that if the 
user zooms in very closely, e.g. to the island of Tahiti (Figure 16), the coarseness of the 
coastline dataset is evident, though it is still of sufficient resolution to use as guidance at 
the community level.  

 
Figure 16. Using background image tiling to view CHG at Tahiti. 

 
A second drawback is that if the user selects background image tiling, and the Offshore 
Wave Amplitude layer, the Offshore Wave Amplitude tends to obscure the background 
map.  The way to mitigate this is to use the Transparency slider at the lower right to make 
the wave amplitude transparent enough to see the place names. 
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Figure 17. Using background image tiling with the Offshore Wave Amplitude layer and 
transparency. 

 

 
Figure 18. Same as Figure 12, but with packaged gray coastal outlines. 

 
The second feature available in TsuCAT is the ability to turn on and off the Place Names 
layer.  While selected, the 30 most populous city/town names are shown at any given 
time.  The packaged city/town names are those with populations greater than 15,000.  
Since all of the country names are shown at all times, the map can get ‘crowded’ with 
labels when zoomed all the way out.  Please note that political borders (shown in blue) 
also come from the GSHHS data set, and, therefore, do not always accurately reflect 
current situations. 

Regional Reports 
 
The ability to create a report of statistics including minimum/maximum offshore wave 
amplitude and earliest/latest wave arrival times for a region has been added to TsuCAT.  
The menu item “File->Export Regional Report” launches a dialog that asks the user to 
first select a country from the drop-down list.  This initializes the region.  The user can 
then zoom and pan to show the best effect of a given tsunami on the region, and the 
statistics update as the user moves the map (Figure 19).  The user can then edit the 
“Region” name for the title of the report, and click “Generate” to save this as a file in the 
application folder called “TsuCATReport.png” (Figure 20).  Note that each time this 
feature is used the file is over-written, so copy this file if you wish to save it. 
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Figure 19: Regional Report creation, showing the dialog with statistic from the given 
region. 

 



Tsunami Coastal Assessment Tool User’s Manual 
 

30 

 
Figure 20: Example report of the southwest Paciifc showing statistics from the effects of 
the 2011 Japan tsunami on the region around Papua New Guinea. 
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User-supplied Maps 
 
The user can overlay a shapefile layer using the menu “File->Add/Remove User-supplied 
Maps”.  This feature allows loading an evacuation area map in GIS file (in shapefile 
format) containing any polygon shapes OR from ComMIT by selecting a Composite 
Wave File exported from ComMIT.  TsuCAT can then render them as a colored, semi-
transparent layer.  This feature is a convenient way to load Evacuation Maps.  The user 
simply clicks the “Add” button and navigates to their shapefile.  The “Name” field is 
initially set to the filename, but the user can edit this for convenience, and set the color 
and transparency level.  This file is then re-projected (if necessary) to WGS84 and saved 
in the application “userMapOverlays” folder.  Several shapefiles can be used in this way, 
and TsuCAT will load them automatically each time it is run. 
 

 
Figure 21: Adding a user-supplied shapefile as a Map Layer. 
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Generating Exercise Messages 
 
This new feature, available only through special password (contact ITIC), gives TsuCAT 
4.3.1 the capability of producing messages that mimic the PTWC text and graphical 
products to assist in preparing for national and regional tsunami exercises such as the 
PacWave and CaribeWave.  For these exercises, PTWC generates sets of regional or 
basin-wide products for a simulated event to aid in training for response to an actual 
event. TsuCAT is similarly able to produce sets of PTWC Tsunami Threat Messages or 
Information Statements appropriate for the earthquake parameters and for PTWC’s 
procedures and protocols. TsuCAT includes in the messages simulated tsunami wave 
measurements at coastal and deep ocean sea level gauges. 
 
To use this new feature, the user simply chooses an event (either by selected from the 
historical database or by moving the epicenter and typing in a magnitude).  Then, from 
the File menu, the user chooses “Generate Exercise Messages”.  This brings up the dialog 
window (Figure 22), adjusts the date of the Exercise, and presses the “Generate” button: 
 

 
Figure 22: The TsuCAT "Export Exercise Messages" dialog with Exercise Injects. 
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Exercise “Injects” are added and customized using the dialog to set the users country’s 
organization names and select the exercise time. 
 
The window has a status/progress bar along the bottom, which shows “…analyzing…”, 
and the progress it makes.  This feature is a fairly intensive process and typically takes 
anywhere from 30 seconds to two minutes.  When it completes, the text bulletin 
Messages are shown on the tab titled “Messages” and the Enhanced Graphical Products 
and shown in the tab titled “Graphical Products”: 
 

 
Figure 23: The Export Exercise Messages window, with a Coastal Tsunami Forecast 
graphic from the Enhanced Products showing. 

 
The user can select the Messages or the Graphical Products to view by clicking on the 
drop-down list.  The lists show the simulated Event Time they were produced for in 
hours:minutes, and a description (e.g. “00:30 Message 2”).  Just as PTWC produces 
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updates for real events every hour, so do TsuCAT … the total event time is calculated as 
the time it takes for waves to fall below 30 centimeters, and for a typical basin-scale 
M8.0 event is anywhere from 6 to 18 hours depending on epicenter location. 
 
The user can click on the “Open Messages Folder” button at the button (Figure 23) to 
view “hard copies” of the products in the format typically dispersed by PTWC for 
exercises: Messages in Rich Text Format (RTF), and Graphical Products in Portable 
Network Graphics (PNG) format.  A typical Tsunami Threat Message is shown below 
(Figure 25) for an M8.8 event in the Aleutian Islands.  Information about the forecast and 
countries affected are listed, as well as Estimated Times of Arrival and Potential Impacts.  
Messages are updated hourly until the event is over. 
 
When using the TsuCAT PTWC Exercise Text Message feature, please be aware that 
even though a real tsunami event can be selected from the Global Historical Tsunami 
Database, the source that TsuCAT uses is the closest source in the TsuCAT catalog and 
Text Messages and Graphical Products produced may not exactly match those PTWC 
produced for the event.  In most cases, TsuCAT will produce slightly higher wave 
amplitudes. 
 
The Exercise Injects file “ExerciseInjects.xls” (Figure 24) is an Excel spreadsheet with a 
suggested timeline and event scenarios to respond to for practice exercises.  This file is 
generated taking information about a given country’s regional forecast office, emergency 
management office, Geophysical Institute and media outlets.  This gives the user a 
timeline as the given event unfolds with very realistic event occurrences, including 
possible magnitude updates, coastal gauge outages, demands for information, and needs 
for forecast accuracy that is designed to test the preparedness for a regional response 
system.  This example allowed the user to choose the country (Chile, in this case) and 
select SHOA as forecast office, ONEMI as emergency management office, Servicio 
Sismológico de la Universidad de Chile (SSUCH) as Geophysical Institute, etc, so the 
injects are region-sensitive. 
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Figure 24: ExerciseInjects.xls spreadsheet, generated from "Add Exercise Injects" 
feature, listing possible scenarios based in the wave heights, arrival times, and 
information regarding user's country supporting offices. 
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For more information on the PTWC Enhanced Products, refer to IOC Technical Series 
no. 105 (rev), User’s Guide for the PTWC Enhanced Products for the PTWS (Aug 2014, 
English, Spanish), or visit the PTWC New Enhanced Products website 
http://itic.ioc-
unesco.org/index.php?option=com_content&view=category&layout=blog&id=2143&Ite
mid=2582 
or the Users Guide 
 
For more information on Tsunami Exercises, please visit the ITIC website on Tsunami 
Exercises, http://itic.ioc-
unesco.org/index.php?option=com_content&view=category&layout=blog&id=1439&Ite
mid=1439 

http://itic.ioc-unesco.org/index.php?option=com_content&view=article&id=1902:ptwc-new-enhanced-products&catid=2143&Itemid=2582
http://itic.ioc-unesco.org/index.php?option=com_content&view=category&layout=blog&id=2143&Itemid=2582
http://itic.ioc-unesco.org/index.php?option=com_content&view=category&layout=blog&id=2143&Itemid=2582
http://itic.ioc-unesco.org/index.php?option=com_content&view=category&layout=blog&id=2143&Itemid=2582
http://itic.ioc-unesco.org/index.php?option=com_content&view=category&layout=blog&id=1439&Itemid=1439
http://itic.ioc-unesco.org/index.php?option=com_content&view=category&layout=blog&id=1439&Itemid=1439
http://itic.ioc-unesco.org/index.php?option=com_content&view=category&layout=blog&id=1439&Itemid=1439
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Figure 25: Typical Tsunami Threat Message issued from TsuCAT. 
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Seismic Expert Regional Sources 
 
Through a collaboration with UNESCO’s Intergovernmental Oceanographic Commission 
(IOC), a series of workshops were held with the goal of identifying regional seismic 
sources that represent the credible tsunami sources with potential impact for regional 
coastlines.  The workshops were held in Haiti (2013), Xiamen, China (2015), Costa Rica 
(2016), Dominican Republic (2016), New Zealand (2018), and Martinique (2019) and 
defined a series of sources for the Caribbean Sea, Central/South America, Tonga Trench 
and the South China Sea.   Sources from these workshops were published in Workshop 
Reports (pdf files of these reports can be found in the TsuCAT/eventSources folder).  The 
source parameters published in these reports were named using the report source name, 
run with MOST/RIFT models, and made available through the “File->Select Expert 
Regional Source” feature (Figure 26).  The maximum offshore wave amplitude, arrival 
time, and coastal amplitude are then accessible in the same way as any other source in 
TsuCAT.  Fault plane parameters from these sources (or any other) can be used in 
ComMIT by using the “View->Fault Information for ComMIT” feature. 
 
 

 
Figure 26: Seismic Expert Source loading in TsuCAT (File->Select Expert Regional 
Source) 
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